Results are different when I use Planet Explorer vs when I use the Planet API V1

I am trying to extract all scenes that have:

* 0% cloud coverage
* 100% visible_percent
* Come from Sentinel/LandSat
* Are in the area {"type":"Polygon","coordinates":[[[-126.47438970831774,71.7742388329718],[-126.47438970831774,72.04403494208917],[-125.6473075290045,72.04403494208917],[-125.6473075290045,71.7742388329718],[-126.47438970831774,71.7742388329718]]]}
* Range in date between June 1 - Sept 1 2020

The Planet Explorer returns 1 result from June 24 with three scenes:

Sentinel2L1C:S2B_MSIL1C_20200614T205029_N0209_R057_T09WWV_20200614T225007, Sentinel2L1C:S2B_MSIL1C_20200614T205029_N0209_R057_T09WXV_20200614T225007, Sentinel2L1C:S2B_MSIL1C_20200614T205029_N0209_R057_T10WDE_20200614T225007

The API returns 10 results from various dates, with 17 scenes:

Sentinel2L1C:S2B_MSIL1C_20200605T201849_N0209_R071_T09WWV_20200605T221756
Sentinel2L1C:S2A_MSIL1C_20200612T210031_N0209_R100_T09WWV_20200613T004156
Sentinel2L1C:S2B_MSIL1C_20200614T205029_N0209_R057_T10WDE_20200614T225007
Sentinel2L1C:S2B_MSIL1C_20200614T205029_N0209_R057_T09WXV_20200614T225007
Sentinel2L1C:S2B_MSIL1C_20200614T205029_N0209_R057_T09WWV_20200614T225007
Sentinel2L1C:S2B_MSIL1C_20200615T201849_N0209_R071_T09XXA_20200615T221803
Sentinel2L1C:S2B_MSIL1C_20200615T201849_N0209_R071_T10WDE_20200615T221803
Sentinel2L1C:S2B_MSIL1C_20200615T201849_N0209_R071_T10XDF_20200615T221803
Sentinel2L1C:S2B_MSIL1C_20200615T201849_N0209_R071_T09WXV_20200615T221803
Sentinel2L1C:S2B_MSIL1C_20200827T202849_N0209_R114_T09XWA_20200827T223854
Sentinel2L1C:S2B_MSIL1C_20200823T205029_N0209_R057_T09WWV_20200823T225149
Sentinel2L1C:S2B_MSIL1C_20200820T204019_N0209_R014_T10WDE_20200820T211421
Sentinel2L1C:S2B_MSIL1C_20200820T204019_N0209_R014_T09WXV_20200820T211421
Sentinel2L1C:S2A_MSIL1C_20200811T210031_N0209_R100_T09XXA_20200812T005010
Sentinel2L1C:S2B_MSIL1C_20200731T204019_N0209_R014_T09WWV_20200731T222121
Sentinel2L1C:S2B_MSIL1C_20200725T201849_N0209_R071_T10XDF_20200725T220437
Sentinel2L1C:S2B_MSIL1C_20200725T201849_N0209_R071_T09XXA_20200725T220437

On closer inspection of the above tiffs, they do not have 100% visible_percent. I copied the filter from the Planet Explorer cURL (and double checked that it matched with the request they were making). I also tried modifying the filter, because it's converted a bit awkwardly -- none of which worked.

This is the corresponding curl request:

curl -u 6ab2f0bf459b425192050bbb09020c83: -H 'Content-Type: application/json' -X POST -d '{"filter":{"type":"AndFilter","config":[{"type":"GeometryFilter","field_name":"geometry","config":{"type":"Polygon","coordinates":[[[-126.4743,71.7742],[-126.4743,72.044],[-125.6473,72.044],[-125.6473,71.7742],[-126.4743,71.7742]]]}},{"type":"OrFilter","config":[{"type":"AndFilter","config":[{"type":"StringInFilter","field_name":"item_type","config":["Sentinel2L1C"]},{"type":"OrFilter","config":[{"type":"RangeFilter","field_name":"visible_percent","config":{"gte":100,"lte":100}},{"type":"AndFilter","config":[{"type":"NotFilter","config":{"type":"RangeFilter","field_name":"visible_percent","config":{"gte":0,"lte":100}}},{"type":"RangeFilter","field_name":"cloud_cover","config":{"gte":0,"lte":0}}]}]}]},{"type":"AndFilter","config":[{"type":"StringInFilter","field_name":"item_type","config":["Landsat8L1G"]},{"type":"OrFilter","config":[{"type":"RangeFilter","field_name":"visible_percent","config":{"gte":100,"lte":100}},{"type":"AndFilter","config":[{"type":"NotFilter","config":{"type":"RangeFilter","field_name":"visible_percent","config":{"gte":0,"lte":100}}},{"type":"RangeFilter","field_name":"cloud_cover","config":{"gte":0,"lte":0}}]}]}]}]},{"type":"OrFilter","config":[{"type":"DateRangeFilter","field_name":"acquired","config":{"gte":"2020-06-01T16:00:00.000Z","lte":"2020-08-31T23:59:59.999Z"}}]}]},"item_types":["Landsat8L1G","Sentinel2L1C"]}' https://api.planet.com/data/v1/quick-search

Can you replicate? Is this a bug? Please help me resolve this, as it is a bit critical for my research.

0

Comments

1 comment

Please sign in to leave a comment.

Didn't find what you were looking for?

New post